Standard generator running out of memory (only trial version?)


I'm a potential buyer and currently toying around with the trial version. Whenever I try to create a larger sector, it stops generate stars with systems around 70,000 - 90,000 stars, or just over 1,000,000 if skipping the systems. When trying anything else I get an "out of memory message". However, if I do a "save as" right after I start the generation, at keep hitting save before reaching the critical point, it seems to chug along (but trying saving after it is out of memory don't work).

I have tried it on two different computers, both with Windows 10 and 16GB of memory.

Is this something that differs between the trial and the full version, something that will be fixed, or something I can configure somewhere?


  • As I never got an answer on this, I didn't got around to buy the software until now. In case someone else is holding back due to my question, I just created a cube with the side of 320ly, each axis divided in 16 for sub-sectoring. That gave 825 302 systems with 16 139 464 total bodies (and a 6GB database).

    I tried one with a side of 500ly, but I guess the database couldn't really cope with that amount of data (at 18GB it had ground to a halt, but it did not crash as the demo version did for me over a year ago).

    The computer is a Windows 10 with 48GB of memory. However, as it is a 32-bit application, the amount of memory part should be fairly irrelevant as 32-bits can't address more than 4GB.

  • At the bottom of the System Generation window there's a spot where you can give it a file name to create during generation. That will let Astro free the data it doesn't need to keep in memory for rendering the map (planets, moons, etc), and thus let it generate larger maps than it'd otherwise be able to make.

Leave a Comment