Program errors on launch

When I launch Mapper 9 it gives three errors:
1. Access violation at address 0000000000F69A93 in module 'Mapper9.exe'. Read of address 0000000000000010.
2. Out of system resources
3. Out of system resources

After clicking Ok to each of them the program launches, but I'm seeing quirks in it like objects being sent to the back layer and any attempt to bring them to the front layer either causes everything else to disappear or has no effect at all.

I've re-installed, downloaded again and re-installed, tried installing on different hard drive: nothing is changing this. I have version 9.01a


  • Do you still have FM8 installed? Open FM8, set the map to something like 100x100 feet with no grid, and close the program. I'm wondering if something in the registry settings is causing FM9 to have problems on startup. If you know how to use regedit, you can delete the FM section:

    Computer\HKEY_CURRENT_USER\SOFTWARE\NBOS Software\The Fractal Mapper\CurrentVersion

  • FM8 is not installed.

  • Ok, apparently FM8 was still installed, but not showing up in Win10 apps settings. I uninstalled it using the uninstall routine in the app folder, but FM9 is still erroring out.

  • I deleted the CurrentVersion in the registry along with the Mapper 8 and Mapper 9 folders. No effect. Uninstalled and reinstalled FM9: it's still giving the first error but not 2 & 3.

  • Try without anti-virus in case that is trying to do something to the executable or prevent it from creating app data directories.

  • Uninstalled, turned off anti-virus and reinstalled--still happening. I should make clear, FM9 runs after the error happens, it just is concerning that this is persistent.

  • Try launching it once as admin in case its not able to create or access a resource.

    If that doesnt work you can try the next update to see if it fixes it. In File -> Program Preferences set the update channel to "Special4" and then check for updates with Help -> Check for Updates.

  • Launched as admin--no effect. Did update--no effect. Ran sfc/scannow--said it found and fixed issues--no effect. Tried running in compatibility mode for win 8, win 7--no effect. Ran an hour long RAM check--no errors. Have checked the C:drive (NVME) for errors--none found. At this stage I'm at a loss for what's going on. The program runs after clicking ok on the error. It's possible I may have some form of hidden malware issue that is protecting this particular memory location, but don't know why FM9 would be the only program affected. Or this may be related to the Webroot Internet Security problem I originally had--maybe an update to that has caused this to start happening.

  • I honestly have no idea what this is related to. I can make a build with some debugging output that could help us narrow down the problem. That may take a couple rounds. Send me an email.

  • I had the same error. I fixed by adjusting the High DPI settings on the executable's Properties/Compatibilities tab. Clicked on Change High DPI settings, then checked both Program and High DPI Override.

Leave a Comment