Commas not allowed in Datastores?

I'm trying to use a datastore as a table for determining species and class characteristics. It works great for simple, uniform, quantitative values like stat modifiers, but I'm running into problems when I'm trying to factor in various qualitative properties, like initial languages and starting feats and things, which have a variable quantity depending on the selection. I'm trying to read them in with an eval() command (I know that's not ideal, don't judge...), and that works fine with individual items. [Trait1] reads in just fine, but when I try [Trait1, Trait2], I can't get it to read in properly. I know that the CSV reads a comma as a field separator, but there doesn't seem to be any way around it in the character designer. I've tried using several methods of escaping the character including the traditional backslash, using two commas, and a few others, and they all do nothing. I've tried enclosing the whole thing in double-quotes, which from what I've researched is the standard method for enclosing commas in data fields. That ALMOST works... It reads the whole thing as a single field, as it should, except the commas within it are quietly omitted. Is there any way include commas in a data field?


  • I have been looking for an answer to this, too. What I have found to work for other .csv files in other software doesn't seem to work here. I also want apostrophes, but couldn't find an answer to that either. Hoping someone will eventually post a solution since my own searches haven't been fruitful.

Leave a Comment