Getting from 0 to all runs of the generator as just blank rows

So I set the generator to run e.g. 5 times, but I'll get anything between 0 to 5 rows with actual results on them, 2-4 seeming more common than the absolute extremes. All possible results from the table itself are showing up.

Here is the code I'm using - well, the actual generator is longer, and does stuff with both values from the prompts, but I'm having the exact same issue with this one. I'm using 3.01b.

Prompt: Choose the number of party members N: {}4 //does nothing in this test
Prompt: Choose a Peril rating (1-8): {Random|1|2|3|4|5|6|7|8}4

Table: PerilProxy
// Peril doesn't actually get used in the Coins table in this test

Table: Coins
Type: Lookup
Roll: 3d6
3-6: $1000
6-9: $500
10-11: $100
12-14: $50
15-18: $10

A sample result from running the above 5 times might be:


But as noted at the start, all results $10-$1000 do show up, and it's possible to get anything from 0-5 blank lines (or conversely, 0-5 lines with actual results).

As you can imagine, I'm quite perplexed by this. The error persists regardless of whether a set value (of 1-8) is inserted for Peril, or the random setting is used, and seems uniform in behaviour regardless of the value of either prompt. Deleting the prompt and the table PerilProxy does make the Coins table thing work perfectly on its own, i.e. so all lines have results. However, note that I copied the prompt & proxy-table structure from the included Treasure/Random Treasure (CR1 - CR30).ipt, which works fine, the relevant lines being:
`Prompt: Choose a CR (1-30) {Random|1|2|3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|22|23|24|25|26|27|28|29|30}1


Table: TreasureProxy
TreasureByCR then uses SRDTreasure.ipt and does some logic and layout stuff. I did delete the ! as in "!CRValue" recently, as according to the IPP help it's an obsolote and no longer required notation for mathematical expressions, but the error persists regardless of whether "Peril" or "!Peril" is used.

Any idea on what exactly is going wrong?


  • edited September 2017

    Hi snaake.

    I copied and pasted your exact code into a new table and ran it. Several dozen runs and I have not gotten a blank line yet. I'm also running v3.01b. Sorry I couldn't be of more help.

  • I also copied your code into IPP 3.01b and ran it. I did 50 iterations and didn't get a single blank line.

  • I also copied your code to see if we were maybe having the same problem but I ran it several times with 1,000 Generators and every line had an appropriate result. I'm also running v3.01b

  • I just solved some of my problems caused by the hyphen character between the dice ranges - my text editor had auto swapped them for their longer counterparts.

    Copying and pasting your code above worked for me but maybe the hyphen character gets reverted when you add it with the markup code (Maybe - I am grasping at straws).

Leave a Comment