prompt problem

I'm trying to get input to work.

I've pasted the exact example from the help file into the editor but it won't prompt for anything. According to the help file:
"Prompts are not displayed when the program is run via the command line interface or CGI." I assume that this is the problem but don't really know.

Here is a picture of my screen: 2017-09-17 09.47.52.png?dl=0

If I am using the CGI, how do I do otherwise? If I'm not using the CGI... does anyone see a problem that I'm missing? That's word for word the example from the help file.


  • If anyone has any ideas....

  • Happened to me when I first began using IPP. I read your post earlier and tried to make it happen again, but couldn't figure out what my original problem was. As I recall, it had nothing to do with the script in my table. It was something to do with saving a brand new table, or saving a new table to the right folder.

    OK, so I just recreated it... When you write a NEW TABLE from scratch, as you F5 (save and run) or Crtl-S (save) then run, it doesn't reload or reinitialize the prompt area in the lower left menu. Just click off that table in the left hand menu to any other table, then back to your new table. After doing this once, the new table is "initialized" and will never have that problem again (hence my having a difficult time recreating it).

    I'm sure I'm using all the wrong language with "initialize" and such, but give it a try - it works, at least for me it does. Now, if you call the .ipt from a command line (i.e. calling a generator from within FWE for example (which is nice to call name generators for cities, mountains, etc), there is no mechanism for a prompt to appear in the program (i.e. FWE) which has a "call IPP"command embedded in it. And if you reference the new table in a USE statement in another table, then the order of prompts (1, 2, 3...) might get out of sequence.

  • Worked. Thank you so much

Leave a Comment