Possible Bugs?


Firstly, can I say that this is a very nifty application and it is very generous of you to offer it for free. I hope that you will take any criticisms in the spirit in which they are intended as I will still use it even if the problems cannot be fixed. I am using it with the even more excellent The Keep, which I use for both game creation and live at the table.

On to the (possible) bugs:

1) I select the text edit field tool and place a field where text is to be inserted. It doesn't always draw it in the right position, sometimes it appears above the location. I then select the pointer tool to highlight the text field to do the fine positioning or change the length of the field. The resize/grab handles don't always appear when I click on the object. Using the area select tool identifies where the resize/grab handles are, which can be on top of each other at the top of the object, or with the lower handles above the upper ones (i.e. above the actual object position).

2) I'm using a text field with a pick list containing all the available skills. Some skills, e.g. Area Knowledge, require editing by the player so the item on the pick list reads Area Knowledge (specify), and the player will then select this and replace the word specify with whatever the game allows, e.g. Area Knowledge (Cairo) or Area Knowledge (Waterdeep). When I run the Viewer and use the pick list to select this item, and then attempt to amend it, it either deletes all the text in the field or only allows me to delete one letter at a time.

3) Assuming that my players are going to end up with about 20 skills, I need to create 20 text fields linked to the skills pick list for them to populate. I select the first text edit field (Skill1) that I have already created and right-click, then select Copy. I then right-click in a blank part of the sheet but all options including Paste are greyed out. I have tried it by selecting the text edit field tool before I right-click on the object to be copied but the highlight jumps back to the pointer tool. However, if I use the Copy & Paste functions on the Edit Menu rather than the context menu, everything works fine.

Thanks for good programs and support.



Leave a Comment