Localized number formats

I just had someone tell me that a generator I shared with them didn't work because I (like Americans) use a decimal point for decimals and he (like a European) uses a comma. He had to find and replace all the decimal points and change them to commas.

It might be helpful if you could add a setting at the start of a generator to indicate the numeric format in order to prevent this issue. E.g. something like


There might be other ways to address it better, that's just the first thing that comes to mind. In any case it might be worth noting in the documentation.


  • Ah, I used to encounter this when the mapper used a text based file format. I'll keep this in mind for the next version of IPP.

Leave a Comment