Cant add PDFs anymore

edited June 2010 in The Keep General
Hi there,

I stumbled upon a little problem with my keep program. As of today i can't add pdf files of a certain size. So my question is:

Is there a limitation to the size of a database in the Keep? I must admit, i don't have that much stuff added right now. Maybe 40 megs of PDFs at the most.

Do you have an idea why i cant add more PDFs?



  • Can you describe what you mean by 'cant add pdfs'? Are the files added, and not viewable? Do they show up in the tree? Do you get any error messages? How are you adding them? If this is Vista/7, do you have the appropriate permissions to write where the files are stored? Can you add other file types? etc.

    There is no practical limit to the number of files or their size in the db. PDFs are stored as individual files anyways.
  • HI Ed,

    Sorry for the lack of information.

    I want to simply add has a child an existing PDF doc to a branch. I go to add child, choose PDF and nothing happens when i choose a 20 megs documents for exemple. Nothing is added in the tree and no error message. I use Windows XP. I have other PDFs in the database and other file types in the database.

    The thing is, if i add this 2 megs PDF doc, it gets added in the tree.

    Anyway. I hope this is clearer


  • There's no size limit to the files stored in the keep. I have several 40 and 50 meg pdf's in my database, for example. Could it be disk space? That would explain why small files could be added but larger ones couldnt.
  • I've made Some more test last night and i found the problem.

    It comes from encrypted documents. Some of the pdfs i wanted to add are pathfinder modules i bought from paizo. Their latest documents are encrypted somehow and i cant load them in the keep. I found a way to remove the encryption and Now i CAN load them. They are not password protected min you. Just encrypted.

    You might watt to look into thaï i guess.

  • ok, I'll keep an eye out for that sort of problem. Not sure why encrypted files cant be added, unless perhaps there's some sort of copy protections preventing them from being physically copied into the database structure. You can also try using the option in Program Preferences to Use External File References, which leaves files in place rather than copying them into the database structure in case thats the source of the problem.
  • I've also got a problem with adding PDFs.

    I get an error about the browser requiring reader version 8 or 9. The PDF appears in the tree, but nothing comes up. I deleted the PDF and tried reattaching it so that I could get the error text, but no error comes up, anymore, it just won't show the PDF.

    -- Update --

    Just tried Use External File References and the pdf attached with an image icon, rather than a PDF icon. But, still, nothing shows in the viewing pane.
  • Do you have the adobe viewer installed?
  • I think so, but I'll check that out...

Leave a Comment