The Keep - database lost

edited July 2010 in The Keep General
Hey Guys,

I've just had a technical issue with The Keep and had to forcefully close it. Since then I can't open the database, or I should say when I open the database it is empty. I can see the file size is still large, and the attachments are all there but I can't get to them.

Is anyone able to help?


  • For starters, what was the 'technical issue' that lead to this?
  • I don't know the specific issue. I was moving from one item in the database to another (specifically I was right clicking on another item higher in the tree to open the context menu) when TK stopped responding. After letting it sit for about 10-15 mins nothing had changed so I forced it to shutdown.

    Reopening TK I found the database now empty. I had tried opening the database directly (I think, I was guessing when I tried it) but it didn't change the result. Of course I was assuming that I picked the right file (it was 3meg in size, but comes up empty regardless).
  • You can zip up the db file and email it to me at the support address. I cant guarantee that the db can recovered but I can take a look to see if it can be. If it siezed up like that - something I've never seen before - the file might be corrupt.

    Do you have any theming software running on your system? I've seen those interfere with menus in the past and cause programs or the entire system to lock up.
  • Hey Ed,

    I've just mailed it to you at the support address. Turns out my key died shortly after my last post which may have been the reason for the lock-up. It took me a while to recover my files, but further testing shows that the db file is still 'empty'.

    Anyway I've zipped the file and sent it to you now. If you can recover it that would be fantastic.


Leave a Comment