Passing variables through multiple tables

Hello all...

A question concerning passing of variables from table to table:

I've got a situation where I call a table with parameter (the character level) being passed through, such as

[@CharacterSkillsPrimary with $CharLevel]

In the Character skill table, I want to call a second table, but have modified the character level to a reduced level, such as

[@SecondarySkills with {!{$1} - 1}]

So, the first pass appears to be work okay for the character skill table - the level comes through no problem and is usable. But the value from the parameter will not pass to the second table. I've also tried doing this:

Set: SecondaryLevel = {$1}
[@SecondarySkills with {!{$SecondaryLevel} - 1}]

A check of the variable value passed doesn't appear as a zero but as a blank, as if the variable itself is not registered. I've tried setting it as a global variable as well further up to see if that might the problem but there is no change.

Have a good day.


  • Try this:
    Set: secondaryLevel = {$1}
    [@SecondarySkills with {!{$secondaryLevel} - 1}]

    Instead of:
    Set: SecondaryLevel = {$1}
    [@SecondarySkills with {!{$SecondaryLevel} - 1}]

    I had problems with some of my variables until I started using lowercase for the initial letter, there also seems to be times when you don't use the $, variables seem to be really hit or miss. Not to mention that their use of the term constant is a bit confusing, they're talking about passing an argument instead of a value. It's just a little weird in the wording.
  • I will give this a try and see what comes up. Thanks much.

Leave a Comment