AdventureHooks keeps breaking-(missing) values FOR NO REASON

So I just found Inspiration Pad Pro and am very excited to start extending the built in tables in "/common". However, every time I try to add new files it breaks some of the Generators.

What is happening is this:

-I have a fresh install of IPP, the AdventureHooks generator works fine, names show up properly
-I have a files named AdventureHooksTEST.idt that are exactly like AdventureHooks.ipt (both the generator that points to the /common file and the /common file itself that has all the "code"). The only difference is that I commented out all the pre-built hooks and just put in some of my own to test it, make sure I did it properly. (I don't want to test hundreds of times waiting for chance to bring up my new entries on the table)
-After doing this, Both AdventureHooks and AdventureHooksTEST don't work in that any reference to a name shows up as "(missing)"

Now this is strange. The TEST file is exactly like the original, but it does not work. Also, why should adding the TEST file break the original? So:

- I delete AdventureHooksTest.idt (both the pointer in /Generators and the actual working code in /Common)

So now we should be back to where we started, I have not edited either of the original AdventureHook.itd files... BUT THEY ARE STILL BROKE. Names show up as "missing". As an added problem, the Treasure generator is no longer working either.

Why is this?

I am using notepad++ to edit the TEST files. After changing the files I exit both notepad++ and the IPP program and restart it. I also tried clicking on the .idt files directly, they are still broken.

I have uninstalled and re installed IPP twice (the only way I know to fix the problem) and redone the steps above. So at this point I am afraid to mess with anything in the common file. How can I extend my tables and make more custom generators for myself if I cannot edit or add files to the common file?

Thanks for the help.


  • Did you alter anything in one of the common files used by AdventureHooks.ipt? If that broke something, that would be an explanation why both that and the copy are missing tables.

    Which version of the program are you using?
  • No, I haven't altered anything that I know of.

    I am running 2.01a.

    PS - I just tried IPP again and got an error about how "TableResults.htm" is in use by another program. I don't know how to fix that, could that be doing it?

    I closed IPP and started it again and the error TableResults error message was not there, but the names were still missing.

Leave a Comment