Generator returns Nothing?

Hi all,

I am working on a relatively huge generator and everything has been working fine so far. Now I added this bit to the top so I do not have to run two separate generators and have the issue that it sometimes returns nothings. As I understood it even with only this code the generator should always return at least NONE or (MISSING). But what happens is that sometimes it generates nothing when I click go. I often have to click 2-3 times until something generates. It happens no matter what terrain type I have chosen in the prompt. I narrowed it down to this but I do not see a reason for this behavior in this bit or am I blind? It drives me up the wall! Thanks for any help.
Prompt: Primary Terrain {Water|Shrubland|Snowfield|Grassland|Forest|Hills|Mountains} Forest
MaxReps: 1

[@1 {$prompt1}MinorEncounter]

Table: WaterMinorEncounter
[@2 EncounterMinorDetector]

Table: ShrublandMinorEncounter
[@4 EncounterMinorDetector]

Table: SnowfieldMinorEncounter
[@2 EncounterMinorDetector] 

Table: GrasslandMinorEncounter
[@6 EncounterMinorDetector]

Table: ForestMinorEncounter
[@4 EncounterMinorDetector]

Table: HillsMinorEncounter
[@4 EncounterMinorDetector]

Table: MountainsMinorEncounter
[@2 EncounterMinorDetector]

Table: EncounterMinorDetector
Type: Lookup
Roll: 1d6
1: [@MinorEncounter&;#93; \n
2-6: NONE \n


  • I copy/pasted it into a file & ran it, and it seems to run exactly as you defined it... either NOTHIN or (missing)

    You say you click and 'nothing' happens. Is anything displayed? ie, is it a blank page that gets displayed, or is it the same results? Could it just be the same set of results getting generated?

    How are you running this? Is it off of a usb drive?
  • I run it installed locally. "Nothing" basically seems to be only a single result but empty. I made a screenshot. I ran it from IP2 and The Keep, same issue. I sometimes must click 3-5 times until I get the expected result.


    More Info: Running on Vista 64 Bit, as administrator though.
  • If you havent already, try that beta posted here. It almost sounds like its having trouble displaying the results file after its generated. The beta, in addition to unicode support, does something slightly different with the results file.

Leave a Comment