Connection Headache - Fixed - Again

OS: Windows XP Home SP3
Provider: Centurylink DSL
Modem: Westell E90-610014-06
--Router: Port 10015 forwarded as per with both TCP & UDP
--Firewall: Off
Win Firewall: Off with exceptions in place to allow ScreenMonkey and port 10015 to go through
ScreenMonkey: Version 1.6g

Player interface from the same computer work. Player access from different computers on the LAN work. ScreenMonkey is able to make anouncements to the NBOS site with the proper ip address. We have no proxy server. Clicking on the link produces the following message in both Firefox & Internet Explorer:

Unable to connect

Firefox can't establish a connection to the server at XXX.XXX.XXX.XXX:10015.
* The site could be temporarily unavailable or too busy. Try again in a few
* If you are unable to load any pages, check your computer's network
* If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web.


For those that are having this problem, I found the solution. If your router/modem has an option to configure a Single Static IP pass through, you need to enable this, assign it to you server computer, and change the IP address of the server to the WAN address. Be sure to leave the default gateway, DNS, and subnetting all the same as before.


  • that looks like its related to something I encountered on mine called 'bridge' mode. Where rather than simply acting as a modem, the dsl modem acts itself as a router, creating 2 distinct LANS, and thus two distinct sets of local IP addresses. The modem has to then be put into 'bridge' mode, telling it to simply pass on its ip to the router, and not act as a router itself.
  • Ok, I was wrong. The static IP passthrough only worked for computers hooked to my own network. Other comps are not able to connect. Everything is the same as above.

  • If you can access SM from other pc's on your network, but not from the internet, then its almost certainly something on the router blocking things.

    Have you looked into bridge mode on that westell? I have a westell, different model, and thats what I have to do got allow incoming connections. Do you have both a physical router and a modem, or is it just a modem thats acting like a router? (ie, you plug the phone line into it, and it also can accept more than one networking cable)
  • I agree with you that its the modem/router blocking. I have the same problem with the other free VTTs I've tried. (OpenRPG, MapTool)

    The Westell is a modem router combo. I also have a Linksys router behind it. It is currently in bridge mode as that was the only way I could get it to give internet access. I have tried having the Westell in both bridge and router modes. The Westell has both a ethernet port and and a usb port. I have tried connecting to both directly with the server computer and still no luck.

  • Ok, NOW it's working. I set the Single Static Passthrough to the computer with SM, let the auto dhcp on the computer stand, and set the port to 80. Confirmed a connection from my end with a proxy site and had a friend in another state connect and move tokens around.

Leave a Comment