Character Sheet Designer/The Keep Problem

edited August 2013 in The Keep General

I've wanted The Keep for quite a while now and bought it during the GM's Day sale at I installed The Keep to my computer (Windows Vista Ultimate x64bit) and also installed Character Sheet Designer.

I cannot seem to get The Keep to open character sheet designs (.csd) from within the program. I can drag and drop .character files into The Keep but that is about it. I followed the directions in the manual for installing character sheet definitions but it still doesnt work. When i go to New Child, the character sheet option is grayed out.

I did see and update to version 1.01b on the website and updated but still no joy.

Can someone help me out here? Is drag and drop the only feature supported for character sheets into the keep. Despite this minor snag, this is a great program!



  • Have you used the Install Character Sheet menu under the File menu? How did you install the Keep... as a desktop app, or in portable mode?
  • I'm having the same problem. I'm running Win XP and installed as desktop app. I've tried going to File/Import Character Sheet Definition and it shows me a list of the character sheets I have on my system. I select any of them and basically nothing happens. When I go to add New Child/Character Sheet, the Character Sheet option is grayed out. I tried dragging a character sheet over and I get a message box saying character sheet it says one character sheet definition installed, but it is no where to be seen. Maybe it is just too late at night to be dealing with this right now.

    Any ideas out there?
  • I've re-downloaded and re-installed character sheet designer/viewer and I still can't get the character sheets to work on my copy of The Keep. This is not the end of the world, but it would be nice to have working eventually.

    P.S. - I still love The Keep!

    Later - Steve
  • I had a similar problem with my installation. To be exact though, mine was a portable installation, but the workaround may work for you guys or others as well.

    I simply created a folder in The Keep's main folder called Character Sheet Definitions and manually copy the .csd file there.
  • I have the same problem unfortunately. I've installed as a desktop application. I can drag the .csd file into The Keep and get a dialog box that says it's been installed, but Character Sheet is still greyed out when I right click New Child. It's not a major problem as I can copy the information into a New Text Entry (or attach the XLS file) but it would be nice to have it working.

    I run Windows 7 Professional (and have tested on both 32-bit and 64-bit PCs - the former being my netbook (which is where I use The Keep) and the latter being my desktop PC (where I installed The Keep just to test this problem)).

    Thanks for any help you can provide.
  • I'm having precisely the same problem. I can't install the character sheet definition, but I can drag an actual character sheet into the tree and have it show up. There is no way for me to make a character sheet entry from within the Keep, no matter how many times I try installing the definition. I'm running the Keep on a portable install, I've moved the .csd file to the stick with the Keep itself, still nothing.

    Fortunately, as long as I can drag sheets to the tree, it still works for me, but it'd be nice if I could create characters internally.
  • I'm a little disappointed if truth be told. The admin Ed_NBOS has been active on the site today (and has posted on the site in the last week - albeit in the Fractal Mapper area) but hasn't deemed it necessary to address the problems we're having.

    I know I said it wasn't a major problem but I would like to see some support for a product I've bought when I have problems with it :(
  • If you need a direct response for something tech support related, its best to email a full description of whats going on to the support email address. In the forum I may or may not see a post. Sometimes I'll answer things if I know the answer off the top of my head, but if thats not the case I may forget about the post as other things come in. If you email to support, on the other hand, it goes into a queue and wont be missed.
  • Fair enough, I'll fire you an email :)
  • Ed has found the solution (or, at least, a solution that works for me). If you run The Keep as administrator (in Windows 7, right click the icon and select "Run as administrator"), adding definitions and characters becomes possible.

    Thanks Ed.
  • Ed has found the solution (or, at least, a solution that works for me). If you run The Keep as administrator (in Windows 7, right click the icon and select "Run as administrator"), adding definitions and characters becomes possible.

    Thanks Ed.

    I tried this (Windows Vista 64) and it still didn't allow me to install a character sheet definition. Or rather it will appear to install the definition, but then still won't allow me to create a character sheet as a new child in the actual database. I still have to create the character using the character sheet program and then drag and drop the resulting sheet.
  • Hi,

    some one can tell me how to use character sheets when I installed both the Keep end the CSG on a USB key?




Leave a Comment