AS3 and FT crashing

Hey there,

I have both AS3 and FT3 installed on a windows 7 x64 machine. Every time i click on a terrestrial planet FT pops up and crashes. If i try to edit a planet surface, FT3 opens up and then crashes before any editing can be done. This happens both on my regular machine and on a fresh install of windows. I'm not sure what is going on. Any ideas?


  • I got the same bug...
    I ran out and bought Astro Synthesis and I bought Fractal Terrains and after spending a bit of money on both it seems the bugs in AS3 prevent them working together....
    Nice bit of software, shame nobody is bothered about solving the issues with it!!!
    This is the second bug in almost the same amount of days.
    Not happy!!!
  • This will create the necessary registry entries to get past the problem. Download and run this program. Click the 'fix FT integration' button, and then run Astro.

    Astro itself will be altered to avoid this problem with the next update.
  • Ok, scrap that. It looks like what you are describing is something different. The fix I posted above is if astro is throwing an error on startup, not FT. I'll look into whats going on with the FT link.
  • Is there anything i can post up to give more information or help?
  • Does FT work ok outside of Astro? ie, if you run it directly.

    Astro3 was tested with the beta of FT3, but its possible something may have changed after that testing. I suspect there's a parameter being passed to FT by Astro thats causing the problem. I'll touch base with PF and see if I can get an updated version of FT to try to duplicated the problem.
  • Hi!

    I got the problem too: editing a surface lead FT to crash. But I noticed on my configuration (Win7, 64b) that when I click on a planet, FT pops and crashes BUT the surface is generated... Only Edit surface calls FT and crashes it with no result (ie, open Ft with the map).

    Aside of this, I can play FT with no issues, and AS3 is pretty fine when FT is not set as surface editor.

  • The same thing is happening to me as above. I can open FT on its own no problem. When AS3 generates a terrestrial planet map it opens FT and crashes, but the terrain is created. Editing a terrain from AS3 causes FT to crash as well.
  • Hi Folks,

    Just following up - the next update to FT will take care of this.
  • Awesome! Thank you very much for the help
  • Hi!

    ProFantasy update FT3 to 3.09. Actually, it appears that Ft no more craches when generating surface map for planet display, but STILL crashes for surface edition... :/

  • Hi again!

    Am I alone to get into that issue from now? Even with the new FT release, I got the crash issue... :(

  • I havent been getting AVs. Are you still getting them? Can you double check that the path to FT in the program preferences is the correct? (in case its running a different installed version)
  • Hi!

    Yep, I still got the problem. I double checked path and settings... If you want, I can make a "video" to show the behaviour of the softwares, one by one and together...

    Am I alone to get issues?
  • Hi!

    I grabbed the new Astro3 beta app and it fixes my FT problem! Great!

    Thanks a lot.

  • Hi!

    Unfortunatelly I have the same problem. In fact, the main reason I've bought AS3 and FT3 is the interoperation between two programs.
    Unfort it doesn't work, when I click on 'edit surface map', ft3 opens and immediatelly crashes (meanwhile generates the image as I see in AS). Before crashing, FT3's title bar shows 'Files'.
    I have the latest update for both programs (AS 3.01d and FT3.0.12) and Windows 7 64.
    It could be nice, if somehow I could export the images (or some kind of metadata) and open it from FT3 - or a fix for the issue... :)

    Thanks in advance
  • I also have this problem using 3.01d and FT 3.04 as with previous poster I purchased so they both could be used together.
    I'm on Win 8.1 x64
  • Tastiger wrote:
    I also have this problem using 3.01d and FT 3.04 as with previous poster I purchased so they both could be used together.
    I'm on Win 8.1 x64

    I am also having the same issue. FT crashes when it generates a surface map AND when I try to edit a surface map.

    It seems like this has been a known problem for quite some time. I tried all of the fixes suggested above, and none of them worked. I tried uninstalling and reinstalling BOTH programs. Nothing seems to work.

    Is there a fix that I'm missing?

Leave a Comment