AS3 Not Saving Changes

Hey, Ed.

I've got the latest version of AS3 - v3.01c - and, suddenly, it has stopped saving any changes I make to a file.

I've imported the T2300 Near Star List into AS3 and it seemed to be working fine. Some changes made last week seem to have been kept. But, I've been updating the file to add system contents and routes, but all the changes would be lost when next I loaded the file. It doesn't matter if I use Save or Save As.

Also, after several attempts, I noticed that the view title at the top of the window doesn't change when I update a system. I add planets by R-clicking and selecting generate contents - regardless of keep name or not - yet the count does not change.

Any ideas?


  • It seems sporadic, but more often than not, it won't save the data. I tried to generate the contents of a system several times, and once it did save the contents.
  • (Its better if you email this sort of thing to the support address - I'll see it sooner.)

    Its certainly not a general problem that I'm aware of. I can send you the current 3.01d build if you want, so you can see if that takes care of the problem. But I'd also recommend checking your disk in case there's a problem with the file system. Also, weird things happen in Windows if you try to save a file into the Program Files directory, so if that's what you are doing that may be the problem.
  • Files seem to be working fine elsewhere and the file is saved in a special RPG folder outside of the Program Files folder.

    I'm using Win8 on a 64-bit laptop, if that matters.

    Just tried again using Save As and the new copy is also not saving any changes.

    Ok, spent some time testing. Created a whole new sector using Ctrl-N to generate the contents - just stars.

    I modified one of the stars using R-click>Generate System Contents (Keep Name) and then saved it.
    Exited AS3 and reopened that file. The change was kept.
    Modified another star in the same way, saved it and exited AS3.
    Reopened the file and it had saved the changes.

    So far, no problem.

    On a hunch, I selected another system and generated its contents as above, but this time picked a star with a good chance of being populated. It was. Saved it and reopened, changes not saved. Now, if I change any stars, population or not, It seems to not save changes. The edit date for the file is being updated, so the file system thinks it's changing.

    It appears that the problem happens once a system is generated that has a population. Or, so it seems. Looks like it saves fine, until a system is generated that has a population.
  • Tried uninstalling and reinstalling AS3a and updated again to AS3c.

    No change. Still seems to fail to save changes once a system is generated with a population.
  • I just uploaded the current development build here:

    You can give that a shot if you'd like. Let me know if this takes care of the problem or not.
  • OK, renamed the old Astro3.exe to Astro3.exe.old. I then unzipped and extracted the new Astro3.exe, copied it and then pasted it to the AstroSynthesis folder.

    I then dbl-clicked the new file and got an error;

    "Astro3.exe - Entry Point Not Found

    The procedure entry point sqlite3_prepare_v2 could not be located in the dynamic link library C:\Program Files (x86)\nbos\AstroSynthesis3\Astro3.exe."

    I'm going to yank out my old WinXP box and see what happens there with AS3c.

    Nope. Failed there, too, but I've never had a problem in the past, that I can recall. Anyway, I guess it's not an issue with being Win8 or a 64-bit machine.
  • I tried going back to just AS3a and got the same problem.

    Updated to AS3c and opened the sector created in AS3a. Same problem.

    I'm at a loss.
  • From that error message, it sounds like that Astro 3.01d beta is using a newer SQLite engine. I updated that zip file to put that in there as well. Just copy both into the install directory, replacing the Astro3.exe and SQLite.dll that you have now.
  • I'll try that tonight.

    On a side note, my Norton is convinced that the NBOS Updater executable is malware and quarantines it. I added it to the exception list, but I'm wondering if that may be part of the issue. I would've thought reinstalling would clear that up, if so, but perhaps there was some sort of unforeseen domino effect that hit something less than evident.
  • OK, that worked.

    I also went back to AS3c, but keeping the new SQLite dll, and that worked, too. So, the problem was apparently with SQLite.

    Should I keep AS3d, or is it still a work in progress and I should return to AS3c until an official release?
  • Good to hear. Not sure what the exact issue was. You can probably keep the new exe, it has some fixes to the travel calculator.

    I have seen the problem with anti-virus software flagging the autoupdater. It seems that anti-virus software will flag nearly anything that attempts to alter files the way an updater does, unless the file is from a well known company. Its a recurring problem for small publishers. I'm actually switching to a completely different approach for the next version of The Keep because of it.
  • Well, I may have spoken too soon.

    After editing about 900 systems, it failed to save all of them; some were saved, some weren't.

    Tonight, I'll try doing them in smaller batches, maybe such a large number of changes overflows a variable somewhere. Oh, and that was using AS3c; I didn't have time to try it with AS3d. I'll give that a go, too.

    At one point, it almost seemed like what hemisphere the edited system was in was a factor, but I didn't have time to pin that down.
  • Further info.

    It appears that those systems that did not save, were populated by R-click>Generate System Contents. Looks like those that were populated by R-click>Generate System Contents (Keep Name) saved fine. I just went through a large number of systems using R-click>Generate System Contents (Keep Name) and all of them were saved without a hitch.
  • Have you switched to 3.01d? Or was this with the older executable?
  • When saving using both methods, that was on both releases.

    I haven't tried the R-click>Generate System Contents with AS3d, yet. Ran out of time last night. I'll take a stab at that tonight.

Leave a Comment